Knowledgebase
When I run the game nothing happens but Steam says it is running
Posted by Lord Victorious (Firefly) on 20 May 2016 12:55 PM

1) Check DirectPlay is enabled (Windows 8/8.1/10)

When running the game on Windows 8/8.1/10 you should be prompted to enable DirectPlay.  Click on "Install this feature" to enable DirectPlay.

DirectPlay Popup

 

If this popup does not appear you can manually enable the option yourself.  Go to Control Panel > Programs and Features > Turn Windows features on or off.  Expand "Legacy Components" and tick "DirectPlay".

Enable DirectPlay

 

2) There maybe a problem with the game configuration file

Sometimes the settings in the configuration file (such as the default resolution) can cause the game not to launch, especially if running the game for the first time in a while or running the game for the first time on a new computer or new hardware component.

 

To reset your configuration please delete the cfg file (we strongly recommend taking a backup of the file first):

1. Log out and exit Steam

2. Delete the cfg file:

The default location of Stronghold stronghold.cfg is located here C:\Users\<User>\Documents\Stronghold\

The default location of Stronghold Crusader crusader.cfg / crusaderextreme.cfg is located here C:\Users\<User>\Documents\Stronghold Crusader\Profiles\crusader.cfg crusaderextreme.cfg

3. Create a backup of the cfg files, then delete the original cfg file

4. Load and log in to Steam *

5. Run the game again

 

* If you are using the Steam Cloud feature (it is on by default) then your problematic cfg file maybe re-downloaded from Steam automatically.  To workaround this you can run Steam in Offline mode https://support.steampowered.com/kb_article.php?ref=3160-agcb-2555

 

 

 

 

 

(17 vote(s))
Helpful
Not helpful

Comments (0)